Visit our Twitter feed for more great content
FordFirst

Ford Trucks Forum

howdy

AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

howdy
#1
mrbarry Avatar
mrbarry michael barry
dover tn, USA   USA
1979 MG MGB "Moanin' Joan"
1991 Ford Bronco
1993 Inline 6 300 CID 5 speed manual ,limited slip front and rear , extended range fuel tanks[ 50 gallons on-board] .. 170,000 miles or so on the odo. been through 2 transfer cases ,one transmission and an alternator , but the engine does not use any oil at all, i can run it for a year with Mobil 1 and never add a quart ,
this old thing has been up the creek and over the mountain more than once

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

Attachments:
ford.JPG    42.4 KB
ford.JPG

mrbarry Avatar
mrbarry michael barry
dover tn, USA   USA
1979 MG MGB "Moanin' Joan"
1991 Ford Bronco
just not a lot of traffic on this net..

..

i was losing brake pedal .. but after 30-40 miles it would pump up for me so i got new pads up front in the Local Napa work Bay .. .
cant not recall when or if it ever got pads up front .. maybe 100,000 miles ago .. maybe never.. and the pads were still above min spec..

new pads and the rear shoes adjusted and it was everso much better ..

service while you wait , i walked across to the barber shop got a hair cut and it was done when i got back ,, cost 100$ installed


shoulda got the rotors turned or new ones since they were pretty Groovy
but times are hard up here on Iron Mountain .. Hardscrabble

i told the Man let 'em eat

1973 midget Avatar
1973 midget Jim M
Salina, KS, USA   USA
Brakes still working out? It's a real good idea to have them turned or replace if they have groves, as you know. Just curies if they lasted very long?

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
mrbarry Avatar
mrbarry michael barry
dover tn, USA   USA
1979 MG MGB "Moanin' Joan"
1991 Ford Bronco
ya no problem with the front brake, got soft again and i had the rear shoes changed ..that is not my problem now..
i have a cooling fault..
the plastic side of the OEM radiator failed and blew out .. i was at idle working on the AC system at the time and it was ,, not good

i got another rad from napa and after doing some log walking in the back lot it blew .. how can this be that the side of a radiator fails w/o the pressure cap releasing or a hose blowing out ?
the first one i just figured it was old plastic but the new one blew after a hour inservice workout.. how can this be?
so i procured a Chinese all aluminum , it fit in good but the in and out was backwards ,, .. i have a work around for that but i still worry why the over pressure and failure of the plastics.. ,, what could have caused this fault , wht should i check ?
ill get back with you and tell my work around on the Chinese alum rad..
regards

m

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions




Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster





Join The Club

Sign in to ask questions, share photos, and access all website features

Your Cars

1999 Ford Explorer

Text Size

Larger Smaller
Reset Save

Sponsor Links